Artifice, Inc.
DesignWorkshop


New Features - DesignWorkshop 1.8


Guide Foyer | Overview | Introduction | Quick Start | New Features | Release Notes
DesignWorkshop 1.7 New Features - since 1.5 | DesignWorkshop 1.5 New Features - since 1.2

Overview

With version 1.8, DesignWorkshop provides a complete, dual platform, solution for live 3D presentations and for professional-quality rendering in addition to its well-established immersion modeling capabilities.

A number of breakthroughs allow DesignWorkshop 1.8 to provide real-time rendering of Lights and Textures faster, more easily, and with higher quality. A new ultra-fast QuickDraw 3D geometry, the trimesh, is fully supported in DesignWorkshop. In addition, any QuickDraw 3D accelerator card is supported. DesignWorkshop now features an easy to use interactive walkthrough interface, allowing you to move through your creations with full lights and textures in real-time. DesignWorkshop include plug-in renderers which provide such high-end features as shadows, anti-aliasing, and transparency without the need for hardware acceleration.


QuickDraw 3D 1.5.1

DesignWorkshop 1.7 has been updated to provide full support for Apple's latest version of QuickDraw 3D, version 1.5.1. You need to have QuickDraw 3D 1.5.1 or newer properly installed to take advantage of the high-end rendering capabilities of DesignWorkshop. QuickDraw 3D 1.5.1 is included on the DesignWorkshop CD. As newer versions of QuickDraw 3D become available, they will be accessible on the world wide web at
http://quickdraw3d.apple.com

QuickDraw 3D 1.5.1 introduced a new form of geometry, the trimesh, which renders several times faster than older geometry forms. DesignWorkshop has complete support of the trimesh. Everything in your DesignWorkshop model will be converted to a trimesh when you view Lights and Textures, and will save as a trmesh when you save a 3DMF file.

DesignWorkshop also features the ability to convert existing 3DMF geometry into trimeshes. To take advantage of this, simply open a 3DMF in DesignWorkshop and choose the View > menu Rendering > Optimize Model command. This feature works on all 3DMFs, whether created in DesignWorkshop or another program, and it can increasing rendering speeds by up to 4 times.


Rendering Plug-ins

DesignWorkshop now supports QuickDraw 3D plug-in renderers which provide more rendering options than the interactive and wireframe renderers that are provided with QuickDraw 3D.

DesignWorkshop includes two plug-in renderers which add new high-end rendering capabilities to DesignWorkshop. The LightWorks SuperLite plug-in makes very high quality renderings on a pixel-by-pixel level. The LightWorks HiddenLine plug-in adds hidden line rendering, similar to what the DesignWorkshop standard window is capable of, to the Lights and Textures side of things. The combination of these renderers along with the standard QuickDraw 3D renderers complete the suite of rendering styles familiar to longtime users of DesignWorkshop: wireframe, hidden line, shading, and shadow casting, now with better quality and speed than before.

In QuickDraw 3D's normal interactive renderer there are no shadows, lights must hit many object vertices to be visible, there is no transparency without additional hardware, and renderings are not anti-aliased. The LightWorks SuperLite plug-in supports all these capabilities, all without hardware acceleration. Shadows are cast from the sun and every other light source in your model. Since renderings are calculated one pixel at a time light sources cast realistic pools of light adding greatly to the rendering quality and ambience. Rendering with transparency are no longer only for people with a QuickDraw 3D accelerator card in their computer, the SuperLite renderer will render non-opaque objects with transparency. The LightWorks SuperLite renderer also supports anti-aliasing which eliminates the pixelated appearance of Lights and Textures renderings, especially noticeable when printing. The LightWorks HiddenLine renderer is comparable to hidden line renderings in the standard DesignWorkshop window. This line-drawing rendering style is great for use as an underlay for making a hand-rendered perspective.

The LightWorks renderers are not included with DesignWorkshop Lite, but if you have those or any other plug-in renderers, they will work with DesignWorkshop Lite. As other plug-in renderers become available you will be able simply put them in your extensions folder and they will be fully functional within DesignWorkshop and DesignWorkshop Lite.


Advanced Viewing Capabilities

DesignWorkshop 1.7 takes the viewing capabilities you are familiar with in the standard DesignWorkshop window and incorporates them into the Lights and Textures window. These capabilities have been enhanced to provide more viewing functionality and control than ever before.

The two-dimensional zoom tools are now fully functional in the Lights and Textures window. As in the standard DesignWorkshop window, with the Zoom-In tool selected, you can click once in the window and the zoom factor will double, or you can drag a rectangle and the view will zoom in to show the contents of the rectangle. The Zoom-out tool allows you to cut your two dimensional zoom factor in half with a single click on the tool icon. You can return to 100% zoom at any time by clicking the zoom percentage number in the tool palette.

The Zoom-in tool also has some exciting new capabilities. If you drag a rectangle while holding down the Shift key the rectangle will draw at the proportions of the current window. This way you will know exactly what will and won't be visible when you release the mouse button. If you hold down the Option key (the Alt key for Windows) as you drag the rectangle you will be able to drag from the center of the rectangle instead of from the corner. That way if you have a point you want to focus in on it is easy to have that point centered and frame everything else exactly how you want it. If you hold the Command key (the Control key for Windows) down as you drag the rectangle you will be able to move the entire rectangle around on the screen. This allows you to adjust your pan and zoom to get it just right. You can use the Shift, Option, and Command keys in any combination (Shift, Alt, and Control for Windows) to compose precisely the view you want.

Views that are set in the standard DesignWorkshop window will now translate to the Lights and Textures window. You can also set views directly in this window. Views set in the Lights and Textures window will not only include the location of the eye and look points, but also your two-dimensional zoom and the brightness of the sun and other model lights. If you save a Lights and Textures model as a 3DMF with set views the views will also be saved and available next time you open the model in DesignWorkshop.


Interactive Walkthrough

DesignWorkshop adds an interactive walkthrough interface in the Lights and Textures side of things. You can easily navigate and walk through your model using only the Walk tool. When you have the Walk tool selected and drag or arrow up and down both the look and eye points move. The result is your entire view moving forward or backward. You can turn to the side using the left and right arrow keys or dragging the mouse to the side. To look up or down hold the Option key (the Alt key for Windows) down and drag the mouse vertically or use the up and down arrow keys. Using these sorts of movements in combination allow you to easily walk through your model, including paths such as walking up stairs.


QuickDraw 3D Accelerator Cards

DesignWorkshop will now automatically recognize and use any QuickDraw 3D hardware accelerator made by any company that you have properly installed in your computer. If you have multiple hardware accelerators you can specify which one to use in the View > Rendering > Graphics Engine sub-menu. You can also force the rendering to be done with software alone.

Most third-party QuickDraw 3D accelerator cards have a monitor port built-in which requires you to hook the monitor up to the card to take advantage of the acceleration. These cards will not be used when exporting a PICT image of the rendering from DesignWorkshop. This is a limitation of the hardware, not DesignWorkshop.


More Flexible Spotlights

In DesignWorkshop 1.7 the illuminating face a spotlight object is determined in a new way which allows greater flexibility and makes it easy to have a spotlight shine in any direction you choose.

The illuminating face of a spotlight object will be the face with the most vertices. If there is more than one face with the most number of vertices the lowest of these faces will be the illuminating face. In the case of blocks the lowest face will be selected, because every face has the same number of vertices.

To quickly make a spotlight that shines upwards use the circle tool to make a polyline circle. Extrude this circle so you have a cylindrical object. Using the trim tool make a trim which goes from the lower end of the cylinder to the side of the cylinder. Delete the corner of the cylinder you just trimmed off. Assign the proper spotlight material to the trimmed cylinder and you have a spotlight that will shine upwards. You can use the rotate tool to orient the light anyway you like and the illuminated face will always be the untrimmed end of the cylinder.

In the 3D libraries we provide a number of theatrical lighting objects which take advantage of this new feature. These lights can be aimed in any direction and the correct face will always light up.


Specularity

QuickDraw 3D 1.5.1 changed the way specularity values are interpreted and allowed us more control over specularity. In the previous version the only component of specularity that you could specify was the glossiness. Now you can specify the smoothness and the reflectivity of a material. Despite this change we have devised a way to keep your models with specularity defined the old way looking just as good as before.

For more information refer to the pages on material types in general, and specularity in particular.


New Metric and Japanese Versions

DesignWorkshop is now available in Metric and Japanese versions.

The Metric version sets the default working unit to Meters, as well as making other settings which are set up specifically for working with the metric system.

The Japanese version has been completely localized for use in Japan. All menus, dialog boxes, and other text is in Japanese if you have a Japanese version of the Mac OS installed on your computer.


Improved DXF Importing and Exporting

DesignWorkshop 1.7 improves importing of DXF files. DXF files will take less memory to import, the results of the import will render faster and require less disk space to save.

Exported DXF models will now be compatible with more software packages. Some software, such as Ray Dream Designer and Lightscape do not support the DXF Polyline entity and can only read the DXF 3DFace entity. 3DFace entities can have no more than four vertices. When DesignWorksop exports a DXF model all faces that have 3 or 4 vertices will be exported as 3DFace entities. Faces with more than 4 vertices will be exported as Polyline entities.


Improved Radiance Export

Radiance exporting of scenes and views has been improved. The Radiance view is calculated more accurately to exactly match the DesignWorkshop view. DesignWorkshop also exports Radiance models so that each object is defined by its material assignment. This allows you to very easily use DesignWorkshop tiling textures in your Radiance renderings. We include all the textures in the Radiance format on the DesignWorkshop CD-ROM, along with documentation for setting Radiance up. For more information see the Radiance folder inside the Accessories folder on the DesignWorkshop CD-ROM.



Overview

DesignWorkshop 1.5 adds fast high-end rendering capabilities to the powerful user interface of previous versions. DesignWorkshop 1.5 supports texture-mapping and rendering of light sources using QuickDraw 3D technology from Apple. DesignWorkshop 1.5 is also much more stable under stress than previous versions, with sophisticated new internal error-handling mechanisms.

Two Kinds of Document Window

DesignWorkshop 1.5 is bimodal, with separate document windows provided for DesignWOrkshop standard viewing and for the new QuickDraw 3D-based rendering.

  • To open either a standard DesignWorkshop model file or a 3DMF file, use the File menu Open... command. DW will open a DW file into a standard window, and it will automatically open a 3DMF file into a Lights & Textures window.
  • To view a DW file using QuickDraw 3D, Open it, and then use the View menu Lights & Textures command.
  • To save a DW file in standard DW format, use the File menu Save or Save As... commands with the standard window at the front.
  • To save any file in 3DMF binary or text format, use the File menu Save or Save As... commands with the Lights & Textures window at the front. Use the radio buttons to select the format option.
  • The Eye and Look tools in the tool palette apply similarly to both types of windows.
  • Modeling tools and the 3D crosshair apply only to the DesignWorkshop standard window.


    Materials, Lights, and Textures

    Materials

    "DW Materials Prefs" and the "Textures" folder --

    Named materials are applied to objects using the Materials pop-up menu in the Object Info floating window. Named materials are used for both lights and textures, as outlined below. The "current material" is automatically assigned to any new objects created. When DW starts up, the current material is "none", but whenever any material is assigned with the Object Info window, DW remembers that as the new current material for any new objects.

    Assigning a material to a group has the same effect as assigning that material to all the objects in the group.

    There must be a "Textures" folder in the same folder as the DW 1.5 application when it starts up, and in the Textures folder there must be a "DW Material Prefs" file. DW will automatically create a new Textures folder and in it a new prefs file, using default values, if either is missing.

    Lights

    - Model lights in DW 1.5 are blocks which have had a light-type named material assigned to them. (This has no visible effect in the standard DW window.) The size of the geometric block of a given light has no effect on the characteristics of the light source. Point lights are placed at the center of the block and send light in all directions. Spot lights are placed at the center of the lowest face of the block, and send light in a direction perpendicular to the lowest face. Spot lights therefore typically shine straight down by default, and they can be directed either by rotating the whole block around one or more axes, or by just tilting the lowest face of the object by dragging on mid-edge handles. Upward shining spots can be made using cleverly-shaped blocks.

    - An assortment of white and colored point and spot lights are defined in the default DW Materials Prefs file for general use.

    - Expert users may also edit their DW Material Prefs to create names and definitions for new lights with any desired characteristics. These material parameters are stored within the DW document when it is saved, but if a material is defined in both places, the values in the Prefs file take precedence over saved values in the document.

    Textures

    - Adding Textures -- A new texture can be added to a project just by dropping an appropriate PICT file into the Textures folder and restarting DW. By default, the name of the PICT texture file becomes the material name shown in Object Info.

    - Named materials already assigned to objects using DesignWorkshop PPC 1.2 will carry over into DW 1.5. However, the textures we are distributing follow an updated naming style. To use old style material names, duplicate and rename some of all of the texture PICTs to match the older names.

    - The actual texture PICT for any material can be changed freely as long as the PICT file name matches the materials used. You can keep multiple sets of textures in different folders, and only the folder exactly named Textures will be accessed. To add a material to a modeling project, just drop a PICT file into the Textures folder and restart DW 1.5.

    - Texture PICTs should be uncompressed PICT files smaller than 512K. We currently recommend saving textures as 16 bit color RGB image PICTs for a good balance between file size and quality.

    - Transparency effects are only rendered with an accelerator board like the Apple QuickDraw 3D Accelerator Card. If an accelerator is present, DW 1.5 uses it by default, but you can turn it off in the View menu.

    - The Apple QuickDraw 3D Accelerator Card supports a maximum of 12 textures at a time. To view more than 12 textures in a model, use the View menu Shading Style > Use Accelerator command to toggle off the accelerator.

    - By editing the DW Material Prefs text file, expert users can set up material names which are different from the associated PICT file names, assign different mapping styles for textures, and adjust the opacity and glossiness for individual textures. Material parameters are also stored within the DW document, but when a material is defined in both places, the values in the Prefs file take precedence over saved values in the document.


    The Lights & Textures Window

    Direct manipulation of objects is not operational in DW 1.5 in the Lights & Textures rendering window. As an aid to scene assembly, when the Arrow tool is selected in the tool palette, the cursor keys can be used to nudge objects in the Lights & Textures window, as if "Select All" is in effect, . Together with the Save and Merge File functions, this basic object moving capability will allow 3DMF files from to diverse origins to be arranged in , although inefficiently. The nudge keys are mapped to move all the objects as follows:

    Nudge Direction -- Left Arrow, WEST. Right Arrow, EAST. Up Arrow, NORTH. Down Arrow, SOUTH, Option-up Arrow, UPWARD. Option-Down Arrow, DOWNWARD.

    Nudge Distance -- with Control, 0.1. Unmodified, 0.5. with Shift, 5.0. with Shift and Control, 50.

    Saving Images

    The File menu Export 2D > Object PICT... command and the Export 2D > Pixel PICT... command both support scaling of PICT output so you can create images with much greater than screen resolution, limited only by available memory and QuickDraw itself.

    New Memory Issues

    When using QuickDraw 3D, the Macintosh operating system needs lots for free memory. Giving too much memory to the DesignWorkshop application will often actually cause memory problems, because this may use up memory need by QuickDraw 3D. Careful reading of low-memory error messages will help you determine whether it is DesignWorkshop or QuickDraw 3D that is running out of memory.


    Changes to Menu Commands

    File Menu

    Edit Menu

    Layout Menu

    View Menu


    Discontinued Features

    The DesignWorkshop 1.5 release does not support Publish and Subscribe. These functions are expected to return in an improved form in a future release.

    DesignWorkshop no longer supports import and export of ClarisCAD files.


    Artifice Foyer | Artifice Index | Guide Foyer | Guide Topics | Guide Index
    © 1998 Artifice, Inc. - All Rights Reserved.