Artifice, Inc.
DesignWorkshop


Quick Start Notes


Guide Foyer | Overview | Introduction | Quick Start | New Features | Release Notes

Quick Setup

  1. Please read this through.   DesignWorkshop® is very natural and friendly to use, but there are a few conceptual issues to understand as you jump in.
  2. Install DesignWorkshop and QuickDraw 3D.  

    To install DesignWorkshop on Macintosh from the DesignWorkshop CD-ROM, copy the folder "DesignWorkshop® Folder" to your hard disk, by simply dragging the folder from the CD-ROM onto the hard disk. That's all there is to it!

    (Note: Metric users should drag the "DesignWorkshop® Metric" folder to the hard disk, and Japanese users should drag the "DesignWorkshop Japan" folder to the hard disk.)

    New Power Macintoshes already have QuickDraw 3D installed. To install QuickDraw 3D on a Macintosh, if it is not already there, open the folder "QuickDraw 3D 1.5.3" on the CD-ROM, then open the folder "QuickDraw 3D Install", and then double-click on the Installer application and follow the step-by-step process.

    To install DesignWorkshop on Windows 95/NT, simply double-click on the "Setup.exe" installer application on the CD-ROM, and then follow the step-by-step process. The standard Windows installation of DesignWorkshop automatically includes QuickDraw 3D.

  3. Set the monitor color depth.   Thousands of colors mode (16 bit) is the preferred color depth setting for DesignWorkshop on both Macintosh and Windows systems. Adjust the system color depth with the appropriate control panel before starting up DesignWorkshop.
  4. Check the system memory settings.   If your Macintosh computer has 32MB or less RAM, virtual memory should be turned on with a total memory setting of 33MB, using the Memory control panel.

    Note that the memory used by QuickDraw 3D (QD3D) is allocated to the System from the free memory when requested by DesignWorkshop. Application memory and rendering memory are separate in DesignWorkshop, and giving too large a memory allocation to the application can actually cause QuickDraw 3D to run out of memory unneccesarily.


Part One -- Moving Around a Building

  1. Start by viewing one of the sample models provided.   To quickly see DesignWorkshop in action with QuickDraw 3D, drag and drop the model file "Maybeck Studio.dw" onto the DesignWorkshop application. This will start up DesignWorkshop and open the building model.

  2. When the application has started up and the model is visible on screen in wireframe perspective in the standard document window, give the View menu Lights & Textures command to open a QuickDraw 3D document rendering window.

  3. When the Lights and Textures window has opened, click on the Eye tool icon in the tool palette, on the left near the bottom. Move around the model, by just dragging with the eye tool in the model window. Drag to the right to go around the model to the right, to the left to go around to the left, and up and down to go higher and lower around the model. Hold down the Option key to move inward and outward with the Eye tool.

  4. Use the View menu Lighting > Sunlight command to toggle the sun off and on, to see night time and day time views.

  5. You can also use the File menu Merge File... command to read in the example 3DMF model Hatchback for Maybeck.3dmf. Switch the Lights & Textures window to Wireframe to see the degree of detail in the models, and for faster navigation on slower Macs without a QuickDraw 3D accelerator board, then switch back to Shading for the fully rendered view.

  6. Practice moving around the model with the eye tool for a couple of minutes until it feels comfortable.

  7. Click to bring the standard window to the front, and try out the different preset views in the standard window, using the View menu. With Hidden Line or Shaded rendering, go to the Plan view, Section, the four Elevations, and back to Perspective. Check and uncheck the Section menu item to turn the sectioning planes on and off. (To adjust the location of the planes, switch to wireframe and use the Layout menu Adjust Section Planes command). Note that with Shadow Casting on (in the standard window), all these views can be seen without having to regenerate the shadows.

  8. Try some of the saved views listed at the bottom of View menu.

  9. When you're looking at one of the saved views that puts you "inside" the model, try out the Look tool. This is the target icon, found near the bottom of the tool palette, right next to the Eye tool. Dragging the Look tool in the model window is like turning your head to look around in different directions.

  10. To move your viewing location forward and backward in 3D, go back to the eye tool. In DesignWorkshop the third dimension is accessed with the Option key. So to move forward, in toward the center of the model, hold down the Option key, then drag the Eye tool upward on the screen. To move backward, hold down the Option key, then drag the Eye tool downward on the screen.

  11. Using first the Eye tool and then the Look tool, you can move around the space dynamically, looking from anywhere, to anywhere.

  12. If you ever get a bit lost in space with the Eye or Look tools, just use the View menu Initial View command to get back to a standard perspective overview.

Part Two -- Basic Building

  1. When you're ready to start building, use the File menu New Model command to open a new model file.

  2. Take a look at the 3D crosshair. First use the View menu Initial View command to get back to a standard perspective overview. Then click on the default Arrow tool at the top of the tool palette, and look in the model space. You should see two horizontal colored lines and one vertical colored line that come together at a point in space. This point of intersection is the 3D working-point of the 3D crosshair.

    As you move the mouse around, you can see the crosshair move around horizontally in the model space. If you push the crosshair out near the distant horizon line, you can see two of the crosshair axes get small. The crosshair is really "inside" the 3D perspective space of the DesignWorkshop model, not just floating across the surface of the computer window like a regular 2D cursor. Move the crosshair around the model space a bit until you get comfortable with it.

  3. The first, most important thing to know about the DesignWorkshop interface is that the horizontal dimensions of the 3D crosshair (x and y) are controlled by simple dragging with the mouse, (as you just experienced) and the third dimension ("z") is controlled by option-dragging.

  4. A handy shortcut to get the crosshair back to zero elevation, right on the ground plane, is to simply type the "0" (zero) key on your keyboard. This is useful if you ever lose track of the crosshair location in space.

  5. In DesignWorkshop, the Option key (the Alt key for Windows) always accesses the third dimension. For instance, the third dimension of the eye tool, which moves your eye point inward or outward from the center of the scene, is similarly accessed by holding down the Option key as you move the mouse forward and backward.

  6. Blocks are created by dragging with the 3D crosshair, in a direct 3D analog to drawing a MacDraw-style rectangle. To make a simple block, click on the Block tool, then move the 3D crosshair to where you want to start drawing the block. Then press the mouse button, and first drag horizontally to draw the plan size of the block, and then, still holding down the mouse button, press the Option key (the Alt key for Windows) and drag up the height of the block. When you see the size you want on screen, release the mouse button.

  7. Objects can be moved around just by dragging them, using the 3D crosshair to move freely both horizontally and vertically. Object handles must be grabbed three-dimensionally, and the Space Jump function makes accurate 3D grabbing quick and easy. To Space Jump, first align the 3D crosshair so the crosshair working-point is visually superimposed on an object selection handle you want to grab. Then, just tap on the space bar of your keyboard to turn the rough 2D visual alignment of the crosshair to an exact lock on the handle in 3D.

  8. Dragging on a corner handle will resize an object, and dragging on any of the white mid-edge handles will move just that edge around, reshaping the object. The object handles must be grabbed three-dimensionally, by eye or by using the Space Jump function.

  9. The other most important spatial location aids in DesignWorkshop are the Projection Lines. Projection lines are drawn on the ground plane for selected objects, like straight-down line shadows. Projection lines let your eye understand how high objects are when they're not sitting right on the ground. They let you see the plan configuration of forms you're moving or creating, right in the perspective view. And by watching the little "foot" on the 3D crosshair in relation to object projection lines, you can tell just where the 3D crosshair is in space, relative to the objects of your model. Projection lines show automatically for any selected object, plus they can be turned on and off for particular objects manually using the Arrange menu.

  10. Be sure to try the Opening tool. Create a wall-shaped solid block, using the Block tool, and leave it selected. Then choose the Opening tool from the tool palette, on the left in the middle, just above the Eye-Dropper tool. Position the cursor over the front side of the selected block, then press down the mouse button and drag a rectangle on the block. This creates a rectangular opening in the block.

  11. To move an opening around the face of a block, choose the Arrow tool in the tool palette, then click in the opening to select it, and just drag it to move it around. The opening behaves just like a MacDraw-style rectangle, so to resize, it, just click select it, and then drag on a corner handle. This works in shaded views, too!

Part Three -- Detailed Building

  1. For advanced users, the Faces mode and the Arbitrary Working Orientations let you tilt, rotate, and place the 3D crosshair alignment to match any specific object in your model. For precise 3D positioning, 3D handle-snapping is provided for most creation and editing operations. Handle snapping is turned on and off with the top right icon in the tool palette. These advanced functions, plus special functions, like Paste into Openings, and specific techniques for creating site models, domes, stairways, various roof forms, etc., are detailed in the DesignWorkshop User Guide.

  2. The DesignWorkshop User Guide also include an illustrated step-by-step tutorial, providing an in-depth introduction to DesignWorkshop as you build a complete model of a small house.

  3. The tools of DesignWorkshop are clear and simple. They are also relatively deep, and with a little effort over several days of practice you will find a fluency developing, leading to a direct, easy modeling style that uniquely supports the three-dimensional design and model-making process.

For More Information...

The Techniques sections of both the printed and online User Guides provide detailed notes on a variety of more specialized modeling tasks. We also post the latest tips and techniques information regularly in the Artifice World-Wide Web area (www.artifice.com).

Please feel free to call us at 541-345-7421 for help answering any technical questions, or send us e-mail at "support@artifice.com". Unlimited technical support is free to registered owners of DesignWorkshop.


Artifice Foyer | Artifice Index | Guide Foyer | Guide Topics | Guide Index
© 1998 Artifice, Inc. - All Rights Reserved.