Artifice, Inc.
DesignWorkshop


Arrange Menu


Tools Reference | Menu Functions | File | Edit | Layout | Arrange | View | Windows
The Arrange menu contains functions that affect the grouping and display of model objects, or change their geometry relative to other objects.

Align Objects >   [ North, South, East, West ]

Align Objects North will align two or more objects along the northern-most face of the objects, and similar alignments for the other directions.

Align Objects >   Vertically >   [ At Top, At Center, At Bottom] ]

Align Objects Vertically At Top will align two or more objects along the top-most face of the objects. At Center will align the centerline of all the selected objects. At Bottom will align all the selected objects at their lowest face.

Fit Object >   [ Upward, Downward, North, South, East, West ]
The Fit Object options are used to extend the selected object in a given direction (Upward, Downward, North, South, East, West) until they hit another object. Just select the object to extend, then give the menu command, and the object will enlarge and adjust the shape of its end face to match the nearest object in the direction of extension. This provides an easy way to match one object to another. For instance, Fit Object > Upward will shoot a flat-topped wall upward to exactly match to the underside of a sloping roof block. Fit Object > Downward can be used to fit a cuboid chimney down onto a sloping roof, without making you think about the slope.

Objects will only extend to fit--they will not get shorter.

Flip North-South
Flip East-West
Flip Vertical

Flip inverts an object (or objects) along the axis you specify. Flip is like making a mirror image of the object. If you select Flip North-South what was the south face will be the north face and vice versa, but the east and west faces will not flip with each-other.


Group and Ungroup

Group and Ungroup work on 3D objects in the typical Macintosh way. Group collects all selected objects into one compound object, and Ungroup does the reverse, releasing a compound object to its parts. Grouped objects can be scaled all together by dragging the handles of the group bounding box. The Trim tool can be used on a group to cut through all the objects in the group at once. The trim crosshair is displayed on the group's bounding box. When moving the view around with the Eye or Look tool, only the bounding box of a group is displayed, effectively simplifying the model to speed the dynamic viewing process.

Hide Objects

Hide makes the selected objects temporarily invisible. As long as an object is invisible, it is also not editable, so it can't be selected, moved, deleted, etc.

Cancel Hide

Cancel Hide makes all the invisible objects reappear; if no objects have been hidden, the Cancel Hide menu is grayed out.

Invert Hide

Invert Hide switches the visibility of everything, so the currently visible objects become hidden and the hidden objects become visible.

To briefly isolate a single object from a large model, for instance for detailed reshaping, select and hide that object, and then "invert the hide", to quickly see it all by itself. Then "cancel hide" to bring back the rest of the model.

The Hide commands provide functionality similar to the Phases controls. The difference is that "hides" are not saved, and are intended for quick showing and "unshowing" of particular objects for modeling convenience. The Phases controls are appropriate for showing and unshowing related collections of objects on a recurring basis.

Show Projection Lines

Show Projection Lines and Cancel Projection Lines turn on and off the display of projection lines for objects when the objects are deselected. Normally, projection lines show for selected objects and objects being created. Turning on projection lines with Show Projection Lines makes the lines stay visible even when the objects are deselected. This is useful for making many kinds of three-dimensional alignments, especially when drawing in the elevation or the arbitrary working orientations.

Cancel Projection Lines

To turn off projections lines for an object, select it and then give the Arrange menu Cancel Projection Lines command. To quickly turn off all projection lines, use the Edit menu Select All command, and then choose Cancel Projection Lines.


Sun & Shading Settings...

Sun & Shading Settings brings up a dialog box for setting the time, date, and latitude to easily and accurately specify the sun angle for Shading, Shadow Casting, and Sun Study... renderings. The time is taken as local time, so the longitude of the model location is not needed.

The Sky Backdrop and Ground Backdrop are not really three-dimensional. They are simply painted behind all objects in the scene, with sky above the horizon line, and ground below the horizon, to economically provide the effect of a whole world. You may want to turn off one or the other of these to see a background PICT image in a shaded view, or to look at shaded solids against a simple white background (with or without the Background Grids).

The ground plane, in contrast to the backdrops, is a three-dimensional object like an infinite flat plane at zero elevation. It provides a surface of "earth", going out to the horizon, for your model to appear to rest on. In wireframe views, the ground plane is not visible and has no effect . In shaded views, to see "underground", or below zero elevation in the model space, uncheck the "Draw Ground Plane" option.

The ground plane provides a default surface for shadows to fall on. For shadows to fall on objects below zero elevation, such as a site model, for instance, also turn off "Draw Ground Plane".

To view your model against a white background, but still get shadows cast onto the "floor", turn off both backdrops, but leave the ground plane on. This is often a nice way to look at furniture or other relatively small objects that don't necessarily exist out in the landscape under a blue sky.

The actual rendering of shading and shadows is activated from the View menu.


Artifice Foyer | Artifice Index | Guide Foyer | Guide Topics | Guide Index
© 1998 Artifice, Inc. - All Rights Reserved.