Artifice, Inc.
DesignWorkshop


View Menu


Tools Reference | Menu Functions | File | Edit | Layout | Arrange | View | Windows

The View menu allows you to choose specific view projections and rendering methods, and it lets you save the current view under a name for reuse later. These choices control the view projection for the current application window (the one in front with the stripes showing in its title bar). Changing the projection or rendering for the current window does not affect other windows.

Plan, Section, Elevation (North, South, East, and West), Perspective, and Axonometric

These views all present the model from the angle you would expect according to the standard architectural definitions of these views. The elevation directions are determined by the compass directions defined for the work space (see North arrow).

Section

To view a pochéd section-perspective, choose Section from the menu. This activates a set of four clipping planes, one of which is applied at a time according to the view direction. Sectioning only affects shaded and shadow-cast views. In a shaded view, if your view looks down from an altitude angle greater than 45 degrees, you will see the model cut and pochéd in plan. When the view direction is flatter than 45 degree altitude, the model will be rendered cut and pochéd one of four ways, so that you see into the cut face closest to perpendicular to the current view direction. The position and rotation of the sectioning planes can be adjusted graphically with the 3D Section Planes Adjuster tool, activated with the Layout menu Adjust Section Planes command.


The next section of the menu controls the rendering of the model on screen: Wireframe, Hidden Line, Shading, Shadow Casting, or Lights & Textures.

Wireframe

The Wireframe rendering method shows all objects as transparent solids, drawing only the object edges. This method is not very realistic-looking, but it is much faster than the other methods, because the Macintosh doesn't have to calculate which objects are blocking the view of other objects. The wireframe method also lets you see through your design as if with x-ray vision.

Hidden Line

The Hidden Line rendering method shows objects as opaque white solids with black edges. The result is similar to a simple non-shaded black-and-white line drawing of the scene.

Shading

Shading adds color shading of each object face, with color ground and sky backdrops turned on by default. The shade for each face of each object is calculated based on the angle between that face and the sun, so faces are rendered with their lightest shade when facing directly toward the sun, and progressively darker as they face more sideways to the sun. Object faces pointing away from the current sun direction are rendered even darker, as they would be in shadow.

Turning on Shading also turns on Hidden Line, so that by default the object edges are drawn as well as the object faces. By selecting Shading and then unchecking Hidden Line, you can shade the model without the object edges being highlighted. This is generally more realistic, but often harder to interpret visually due to the absence of light variations in flat shading. Distant surfaces of the same color which happen to be at the same angle to the sun may not appear to separated at all without the object edges drawn.

Note: To see a Background PICT (opened from the File menu) when using Shading, you have to turn off the display of the sky and/or ground backdrops using Sun & Shading Settings.

Shadow Casting

The Shadow Casting menu item turns on calculation of shadows cast by the sun. Shadow-cast renderings are computed by a fast object-oriented method, and generally take only around twice as long as a shaded rendering of the same scene. These renderings can be saved as object drawings with the File menu Export functions, and they print similarly to other rendering types. The sun angle is set by time, date, and latitude in the Arrange menu Sun and Shading Settings dialog box, as are the display and color of ground, sky backdrops, and flat ground plane. The ground plane defaults on so there is something to cast shadows onto.

Lights & Textures

Converts current DW model to a 3DMF model and renders it in a new window using QuickDraw 3D. Objects assigned materials will be rendered with the material and light sources will shine in this view. This menu item is not active if QuickDraw 3D is not installed.

Update Lights And Textures

If you are switching between the DW version and the 3DMF version of your model, you can make changes to the DW version, switch to the Lights and Textures window and select this menu item and your 3DMF model will reflect the changes you made to your DW model.




Lighting >   Sunlight

Toggles the sun on and off in the Lights & Textures window.

Lighting >   Brighten Sun

Makes the sun one step brighter in the Lights & Textures window.

Lighting >   Dim Sun

Makes the sun one step dimmer in the Lights & Textures window.

Lighting >   More Contrast

Raises the contrast level one step in the Lights & Textures window.

Lighting >   Less Contrast

Lowers the contrast level one step in the Lights & Textures window.

Lighting >   Brighten Model Lights

Makes the lights in your model (not the sun) one step brighter in the Lights & Textures window.

Lighting >   Dim Model Lights

Makes the lights in your model (not the sun) one step dimmer in the Lights & Textures window.



Rendering >   Renderer

This menu will list all your rendering options associated with QuickDraw 3D. If you have plug-in renderers installed on your computer they will be available here.

Rendering >   Renderer >   Configure Renderer

Some plug-in renderers can be configured to your liking. If the selected renderer can be configured this menu item will be active and selecting it will bring up a dialog box for configuring the renderer.



Rendering >   Shading Style >   Flat Shading

Changes QuickDraw 3D shading style from Per Vertex to Flat Shading in the Lights & Textures window. Flat shading will generally be less realistic because specular highlights and other such details will not be rendered.

Rendering >   Shading Style >   Per Vertex

Changes QuickDraw 3D shading style from Flat Shading to Per Vertex in the Lights & Textures window. Per vertex shading is the default and will tend to provide more realistic renderings than flat shading.



Rendering >   Graphics Engine >   Best Choice

If a QuickDraw 3D accelerator card is present will render using the card. If there is no card present DesignWorkshop will render using Apple Software. This option is selected by default.

Rendering >   Graphics Engine >   Apple Software

Select this item if you have a QuickDraw 3D accelerator card but want to force the rendering to be done without the card.

If you have one or more QuickDraw 3D accelerator cards installed each one will also be listed in this menu. You can select any accelerator card listed to render with that card. The LightWorks plug-in renderers and every other plug-in renderer currently available do not take advantage of accelerator cards. Only Apple's interactive renderer (the default QuickDraw 3D renderer) take advantage of accelerator cards.



Script Walkthrough >   Setup...

Displays the Walkthrough windoid. See the section on DesignWorkshop Windows for more information.

Script Walkthrough >   Run...

This command displays a dialog box where you choose to save the walkthrough as PICTs and or a QuickTime movie, then the walkthrough is run and saved.

Sun Study

The Sun Study... command generates a series of images for a single-viewpoint, time-lapse, animated sun study, with a small clock placed in the lower right corner of each frame indicating the solar time. Define the time-extent of the sun study by entering the starting time and ending time. The fineness of the time-lapse effect is controlled by setting the number of frames to be rendered. For hour-by-hour views, specify a frame number one greater than the time-span of the study in hours.

The sun study will be rendered in a special square window, using the size specified in the Sun Study dialog box, with its projection based on the current view in the modeling window. The sequentially rendered frames of the sun study can be saved as individual numbered PICT files, as a QuickTime movie, or both. QuickTime movies are usually relatively small for animation files.

Rendering many frames in a single batch may require an increase in the DesignWorkshop memory partition. To increase the memory partition, go to the Finder when DesignWorkshop is not running, and use the File menu Get Info ... command to open the Info window. Then, type a higher value into the application memory size field at the bottom right of the window. Close the Info window to enter the new setting.

Sun studies saved as QuickTime movies can be played back with the Apple MoviePlayer application (also included in the DesignWorkshop distribution). The MoviePlayer window includes VCR-type play controls along the bottom. In MoviePlayer, you can set movies for continuous looping or back-and-forth play. Click on the triangular button near the left end of the control bar to run your movie. You can also scroll back and forth to any time by dragging the sliding handle on the control bar.


Set View

Set View saves the current eye and look points under the name you specify, which is automatically added to the bottom of the View menu, so you can get back to a useful view quickly and exactly. The first several saved views are automatically assigned numbered command-key equivalents.

Saved views provide the basis for walkthrough calculations, and can be rendered as a batch through the Walkthrough floating window.

Edit View

Edit View opens the Views windoid, where unnecessary views can be deleted. (See the Views Floating Window description for details.)


Artifice Foyer | Artifice Index | Guide Foyer | Guide Topics | Guide Index
© 1998 Artifice, Inc. - All Rights Reserved.