Artifice, Inc.
DesignWorkshop


DesignWorkshop Windows: Lights and Textures


Standard Document | Lights and Textures | Phases | Object Info | Views | Walkthrough

DesignWorkshop has two different windows for viewing models, the standard window and the Lights and Textures window. The standard window is where you create and edit models. It is also the window for most renderings. The Lights and Textures window is for rendering with QuickDraw 3D. The Lights and Textures window will render materials assigned to objects and will calculate light sources in the model.

To open the Lights and Textures window from a standard DesignWorkshop model select the Lights and Textures item from the View menu. This will convert your model into a 3DMF model and render it using QuickDraw 3D.

You can switch between the standard window and the Lights and Textures window at will. You can make changes to the model in the standard window and then select Update Lights and Textures from the View menu to see the changes in the model rendered using QuickDraw 3D.

Another way to open the Lights and Textures window is by opening a 3DMF file saved by DesignWorkshop or any other QuickDraw 3D capable application.

You can save the model displayed in the Lights and Textures window as a 3DMF in either binary or text format, binary is smaller and will usually be the preferred format.

Though you can not create objects in the Lights and Textures window you can move the model as a whole. You need to have the Selection (arrow) Tool active and then the arrow keys will change the position of the model. With the control key held down the nudge distance is 0.1 working units. With no modifier key held down the distance is 0.5 working units. With the Shift key held down the distance is 5.0 working units. With the shift and control keys held down the distance is 50 working units.

You can adjust the lighting in the Lights and Textures window by turning the sun on and off, changing the brightness of the sun, changing the brightness of lights within the model and changing the contrast. This is all done in the views menu.

You can merge an existing 3DMF file with the currently open Lights and Textures model by selecting Merge File from the File menu. You may need to reposition one of the models before merging them so they line up properly. Do this using the arrow keys as previously described.

The Eye and Look Tools are fully active in the Lights and Textures window allowing you to navigate throughout the model. The movement of the eye and look point follows the DesignWorkshop standard rather than the movement you may have experienced in other QuickDraw 3D applications. Other applications seem to be you remaining in place and moving the model around and twisting it about your fixed point. In DesignWorkshop the model is fixed in place and you move through the space and change the direction you are looking. The DesignWorkshop approach mirrors reality for architectural purposes.


Artifice Foyer | Artifice Index | Guide Foyer | Guide Topics | Guide Index
© 1998 Artifice, Inc. - All Rights Reserved.