Artifice, Inc.
DesignWorkshop


Troubleshooting


Guide Foyer | Guide Topics | Guide Index | Overview | Tools Reference | Techniques

General Issues


General Issues | Modeling | Lights and Textures | Translation | Conflicts

System Requirements

DesignWorkshop for Power Macintosh requires a PowerPC processor, Mac OS 7.1.2 or higher, QuickDraw 3D, and a minimum of 16MB total RAM. 32MB of RAM is recommended.

DesignWorkshop for Windows requires a Pentium processor, Windows 95 or Windows NT 4.0 or higher, QuickDraw 3D, and a minimum of 16MB total RAM. 32MB of RAM is recommended.


Memory Requirements

Probably the majority of Macintosh software problems stem from insufficient memory. Read this section, and see also Memory Usage (immediately below).

If your Macintosh has 32MB or less RAM, virtual memory should be turned on with a total memory setting of 33MB, using the Memory control panel. Note that the memory used by QuickDraw 3D (QD3D) is allocated from the free memory when requested by DesignWorkshop. In other words, application memory and rendering memory are separate in DesignWorkshop, and giving too large a memory allocation to the application can cause QD3D to run out of memory unneccesarily.

While DesignWorkshop is running, you can switch to the Finder, and use the Apple menu "About This Computer..." command to see a graph of current memory usage. In addition to observing the memory size and utilization for DesignWorkshop, note the System memory size, and the size of the largest free memory block.


Memory Usage

Running out of memory may cause unpredictable problems for either DesignWorkshop itself, or for the QuickDraw 3D graphics system. The memory needed by DesignWorkshop itself varies according to the size and complexity of the models being used, the number and size of open document windows, the style of rendering and monitor color depth, etc.

A rough but useful rule-of-thumb for predicting DesignWorkshop application memory usage, under general conditions, is to start with 10MB for the DesignWorkshop application itself, and then add 1MB of additional RAM allocation for each 100KB of model size. For instance, a 100KB model can be edited and viewed comfortably in an application memory partition of 11MB, and a 1MB model can be edited and viewed comfortably in an application memory partition of 20MB.

QuickDraw 3D seems to work best with at least 8-16 MB of free memory, and it will need more for larger windows, larger models, and when rendering many textures. The memory used by QuickDraw 3D is drawn from the free memory on the computer, not from the DesignWorkshop memory partition. When QuickDraw 3D claims additional memory, in Mac OS 7.x it will show up in the System memory partition, and in Mac OS 8.0, it will show up in the DesignWorkshop partition (using the Apple menu "About This Computer..." command from the Finder).


Correct QuickDraw 3D Versions

For DesignWorkshop, QuickDraw 3D 1.5.1 or higher is required. The QD3D 1.5.3 Installer from Apple is included on the DesignWorkshop CD-ROM.

For DesignWorkshop 1.5, we recommend using QuickDraw 3D 1.0.6. The QD3D 1.0.6 Installer from Apple is included on the DesignWorkshop 1.5 CD-ROM.


Printer Must Be Defined

DesignWorkshop checks the current printer when starting up and initializing its graphics environment. As a result, you may have trouble starting up DesignWorkshop if for any reason no printer has been defined with Chooser on your Macintosh. This can happen if the computer is new and no printer has been chosen yet. It can also happen after a system upgrade or printer driver upgrade, which might overwrite the previous choice and leave the current printer blank.


Modeling Issues


General Issues | Modeling | Lights and Textures | Translation | Conflicts

Your Model Looks Very Small and Far Away When Opened

If you open a DesignWorkshop model and discover that your model looks very small and far away, there is probably a straightforward explanation and a quick solution.

DesignWorkshop calculates the Initial View each time it opens a model, based on the actual overall dimensions of the model. The initial view is established so that it shows most of your model at once, and not too much else. Usually a small and far away model is caused by extra objects in the model file, far beyond what you expect to be the bounds of your model.

To eliminate these extra objects and normalize the Initial View, first go to Plan view and drag a rectangle in the middle of the view to select all the objects of the model that you want to keep. Put away these objects temporarily with the Arrange menu Hide command. Then use the Edit menu Select All command to select any and all outlying objects, and use the Delete key (the Backspace key for Windows) to delete these unwanted objects.

Next, use the Arrange menu Cancel Hide command to show the main model objects again. Finally, use the File menu Save As... command to save your model (with a new name, for safety!) and close the model. When you reopen the file, you should see the model framed nicely in the Initial View again.


Lights and Textures Rendering Issues


General Issues | Modeling | Lights and Textures | Translation | Conflicts

Transparency Doesn't Seem to be Rendering

For transparency effects to be visible with QuickDraw 3D, it is required to have either QuickDraw 3D hardware acceleration, or an appropriate plug-in rendering module.

The LightWorks SuperLite plug-in renderer, included with DesignWorkshop Professional, will render transparency effects nicely. In the Lights & Textures window, use the View menu Shadowcasting command to render with the SuperLite plug-in.

If the Shadowcasting command is grayed out when you are looking at a Lights & Textures window, this indicates that the plug-in renderer is not properly installed. Check the "DW Plug-ins" folder which is in the same directory as the DesignWorkshop application for the presence of the "LightWorks SuperLite" plug-in.

Some computers, such as the entire G3 line of Power Macintoshes, already include a QuickDraw 3D hardware acceleration chip on the motherboard.

With QuickDraw 3D hardware acceleration installed in your computer, either as a chip or an add-in board, you should be able to see transparency effects in the Lights & Textures window, using the View menu Shading command.

If you have QuickDraw 3D hardware acceleration installed and you can't see transparency effects with the simple "Shading" command, you should check carefully to make sure that the proper QuickDraw 3D extensions and any vendor-specific system extensions are installed, as required by the hardware accelerator.

Many non-Apple hardware accelerator add-in boards require that the monitor cable be connected directly to the board, rather than to the built-in video of your Macintosh.

If a hardware accelerator board is properly installed, and all its extensions are properly installed, and the monitor cable is in the right place, and you still can't see transparency effects in the Lights & Textures window, then most likely your system is running out VRAM, the special video memory often used both for the screen display and for texture acceleration.

To check whether a video memory shortage is preventing transparency effects from working, you can try rendering in a way that uses a minimum of VRAM: 1) Switch your monitor settings so you are viewing at 640x480 resolution, with thousands of colors. 2) Quit all applications except the Finder. 3) Start up DesignWorkshop with an Untitled empty model, and draw a single cube in the middle of the modeling world. Then assign the Glass-Clear material to the cube. 3) Use the Lights & Textures command to open the cube into a QuickDraw 3D rendering window. 4) Make the Lights & Textures window very small, something like 2"x2" (6cm x 6cm). 5) Now, drag around with the Eye tool, and see if you can see the horizon line through the cube.

If you can see through the cube at step 5) above, but not when you view it in a larger window, then you are running out of VRAM. Depending on the CPU or accelerator board you are using, your VRAM may be expandable, usually at a modest cost.


Some Textures Don't Seem to be Rendering

The Apple QuickDraw 3D Accelerator board only supports rendering of 12 textures at one time. Additional texture map assignments will be ignored when rendering with hardware acceleration.

To render more than 12 textures at one time when the Apple board is installed, check the View menu Rendering > Graphics Engine > Apple Software menu item to turn off the hardware rendering engine. The textures will then be rendered by the QD3D Interactive Renderer in software.

Other hardware accelerator boards may show their memory limits in other ways. With ATI boards, for instance, when the on-board texture memory capacity is exceeded, the board keeps rendering, but the amount of acceleration drops very significantly.

See the section above for steps on rendering in QuickDraw 3D with a minimum of memory, which is useful for acceleration tesing purposes.


A Texture Renders Poorly or Causes Crashes

Texture PICT files added to the "Textures" folder must be saved without JPEG compression. They should have a resolution set to 72dpi. If the dots-per-inch is greater than 72 the textures may render poorly, with only part of the image displayed, and with a dark stripe along the bottom of each image tile. (The greater the dots-per-inch, the worse these effects will become.) If a texture PICT file is saved at less than 10dpi, it may crash DesignWorkshop when loading. You can easily check and modify the resolution for a PICT image file using Adobe Photoshop (with the Image Size functions in the Image menu in Photoshop).


Lights Don't Seem to be Rendering

See special note on the effects of rendering with vertex interpolation, Lights Don't Seem To Shine.


Shadows or Objects are Missing when Using the LightWorks Renderer

The LightWorks SuperLite plug-in renderer version 1.2, which was included on the DesignWorkshop 1.7 Release One CD-ROM, is unpredictable when rendering models with the trimesh geometry type introduced in QuickDraw 3D 1.5. If you find objects or shadows appear to be missing after rendering with the SuperLite plug-in in DW 1.7, we suggest you take advantage of the free upgrade to the latest DesignWorkshop CD-ROM which includes an updated version of the plug-in renderer. To order your upgrade contact Artifice Sales by email at sales@artifice.com or by telephone at (541) 345-7421.


Translucent Objects Don't let Light Through in LightWorks Renderings

For shadow-casting purposes (though not for direct viewing purposes) the LightWorks SuperLite renderer, used with the Lights & Textures Shadowcasting command, treats objects with translucent or transparent materials as though the object is opaque, so it casts solid shadows. For instance, indoor lights will not shine through a glazed window and light up the ground outside. Similarly, light will not shine through a translucent lamp shade, even though you see through it.

This can seem confusing, because the default Interactive Renderer (IR) used with the plain Shading command lets lights shine through freely. However, that is just because the IR doesn't do any shadowcasting at all. With the IR, lights shine through everything equally, whether opaque or transparent. In contrast, with the LightWorks Superlite, shadows are cast by everything, whether opaque or transparent.

Forthcoming, higher-level plug-in renderers by LightWork Design are expected to provide more sophisticated shadowcasting options.

To simulate the visual effect of both the shadows and the light transmission created by a translucent object, you can use double light sources. For instance, for a detailed LightWorks rendering of a floor-standing lamp with a translucent shade, you can put one point light source inside the lamp shade, and then hover another very tiny point light source in mid-air a couple of feet or more above the lamp.


Alpha-Channel Transparency Doesn't Work with LightWorks Renderings

The LightWorks SuperLite renderer does not support alpha-channel transparency in textures. This effect is also known as "transparent pixels" or "pixel transparency", to distinguish it from the effect of overall-transparency for textures, which is supported.

Pixel transparency is supported in the plain "Shading" command.


Translation Issues


General Issues | Modeling | Lights and Textures | Translation | Conflicts

Problems Importing to DesignWorkshop

The most common source of difficulty when reading in large drawings via DXF or Object PICT format is insufficient memory to hold the drawing in DesignWorkshop. Even simple drawings will sometimes require much more memory when converted to 3D in DesignWorkshop. It is a good practice to simplify any 2D drawing before exporting so that only necessary objects will be loaded into the 3D modeling space.

However, with so many possible applications and configurations, it is inevitable that unusual translation problems will arise. Please don't hesitate to contact Artifice Technical Support for the latest information and assistance.


PowerCADD to DesignWorkshop

To convert PowerCADD 2D drawings seamlessly into DesignWorkshop 1.5, start in PowerCADD by simplifying the drawing for export. Then use the PowerCADD File menu Save As... command, selecting the "DesignWorkshop" file format in the pop-up menu of the save file dialog box. This produces a special customized PICT file with a DesignWorkshop-style icon. (If DesignWorkshop does not appear in the pop-up menu, then the DesignWorkshop XTNL translator module is probably not properly installed in the PowerCADD XTNLs folder.)

To read the custom PICT drawing into DesignWorkshop, first open a model in DesignWorkshop, then use the File menu Import > Object PICT command. The rest is automatic, and the drawing should appear with its upper left corner aligned to the 0/0/0 point in the DesignWorkshop model space.


DesignWorkshop to PowerCADD

Any DesignWorkshop screen image can be exported as a general-purpose PICT file, and then opened in PowerCADD. However, only views with uniform scaling, including plan, section, elevation, and axonometric, can be translated using the special PowerCADD Scaled PICT command. If you are not in one of these particular views, the command will be disabled.

To convert a drawing from DesignWorkshop to PowerCADD from an appropriate view, use the File menu Export 2D > PowerCADD Scaled PICT command to create the drawing file. This produces a special customized PICT file with a DesignWorkshop-style icon.

To read the custom PICT drawing into PowerCADD, use the File menu Open command, selecting the "DesignWorkshop" file format in the pop-up menu of the save file dialog box. (If DesignWorkshop does not appear in the pop-up menu, then the DesignWorkshop XTNL translator module is probably not properly installed in the PowerCADD XTNLs folder.)

The drawing should appear in a new PowerCADD document window, scaled to 1/8" = 1' - 0". You can adjust the drawing to another scale if necessary using the various editing and drawing setup functions of PowerCADD.


MiniCAD to DesignWorkshop

This process involves three steps: (1) prepare a drawing or model in MiniCAD 6.0.3; (2) export the drawing in DXF format; (3) import it into DesignWorkshop. The process will be similar for other CAD programs which support the DXF file format.

1) Simplify the drawing in MiniCAD.

There are probably some objects in the drawing that should not be translated to DesignWorkshop, because they are unnecessary and may greatly increase the memory needed. Working on a copy of the drawing in MiniCAD, you should delete graphic objects like dimension lines, dotted lines, and plotter-type hatching which are not directly part of the project you are modeling. Dashed lines and hatching are particularly hard to import from some applications because each line fragment may be imported as a separate graphic object. This devours memory quickly in DesignWorkshop.

2) Once the non-essential objects have been edited out of the original MiniCAD drawing, then export the drawing.

Give the File menu Export -> Export DXF command. In the dialog box this brings up, set the pop-up menu so the top line says "Export as DXF Layers". If your MiniCAD file is just a 2D drawing in MiniCAD, set the radio button to "Export 2D Objects Only". If the drawing includes 3D objects, set the radio button to "Export 2D and 3D Objects", and also check "Decompose 3D Symbols into 3D Polys". Click the "Export" button, which will close that dialog box and bring up a standard Macintosh 'Save File' dialog box. Save the DXF file wherever you want it. For DesignWorkshop, there are no limitations on DXF file names, but there are restrictions in some other applications, so it's good practice to have DXF file names end in ".DXF".

3) Import the file into DesignWorkshop.

After exporting the file, quit MiniCAD to free up as much RAM memory as possible for DesignWorkshop. Check the memory setting for DesignWorkshop by selecting the application icon in the Finder then and in the Finder giving the File menu Get Info command. The Minimum and Preferred memory settings for DesignWorkshop should be kept the same to avoid any confusion on how much memory DW is actually getting. The more RAM you allocate to DesignWorkshop, the fewer import problems you'll encounter. Close the "Get Info" window in the Finder.

Start up DesignWorkshop, with an empty new model. Use the File menu Import -> DXF Drawing Or Model... command. In the "Open File" dialog box that comes up, select the DXF file you just exported from MiniCAD, and then click the "Open" button. DesignWorkshop will read the file and import all the objects into the current DesignWorkshop model. Note that in DesignWorkshop, you don't get any feedback until this process has finished.

Save the DesignWorkshop model with the imported objects. If you can't see any objects, it is possible that they are present, but outside the current view. To check on this possibility, close the saved file, and then re-open it. (Whenever you open a file in DesignWorkshop, the initial view is calculated to show all the objects.)

If you close the model, it is a good idea to check the size of the DesignWorkshop file in the Finder, and make sure that DesignWorkshop has been allocated enough memory to work with it. Use the allocation rule-of-thumb of 10MB of RAM for the DW application itself, plus another 1MB of RAM for every 100K of model size.

(Remember also that for QuickDraw 3D rendering in the Lights & Textures window, the Macintosh needs to also several MB or more of free memory outside of DesignWorkshop for the System.)

When you have confirmed that the objects are present, you can go to work on the DesignWorkshop model like any other file.


DesignWorkshop to MiniCAD

The process for exporting a DXF from DesignWorkshop for use in MiniCAD is considerably simpler than exporting from MiniCAD.

1) The first step is to decide whether you want to export a 3D DXF model, or a 2D DXF drawing.

If you are exporting a DXF drawing from elevation or axonometric view the exported drawing will be based on the current view. If you are exporting a DXF drawing from plan or perspective the exported drawing will be a plan. If you are exporting a DXF model the current view is irrelevant because all objects will be exported as three dimensional objects.

2) When you export a DXF from DesignWorkshop all the currently visible objects will be exported, so you should turn off phases or hide objects that you don't want exported.

3) From the File menu Choose Export 2D -> DXF Drawing or Export 3D -> DXF Model depending on what sort of DXF you want to export. Choose a name for the file. Some applications will require that DXF files end in .dxf and that is probably good practice anyway just so you can easily keep track of files.

4) Before importing the file to MiniCAD you have to set the scale of your MiniCAD drawing. To do this go to Page -> Scale and choose the drawing scale at which you want to work.

5) With your MiniCAD drawing open choose File -> Import -> Import DXF. Choose your file in the dialog box. Choose the options you want for the DXF import.

6) You should now have your DesignWorkshop model successfully converted to DXF and imported to MiniCAD. You can work on it as you would any MiniCAD drawing.


Problems with DXF Export to Other Applications

The DesignWorkshop DXF Export functions have been updated in DesignWorkshop for maximum compatibility with the widest range of other 2D and 3D applications. Few problems should be experienced in normal usage.

The most common source of difficulty with taking models from DesignWorkshop to another 3D application via the DXF format is that some receiving applications cannot handle all the complex polygons produced from translating the solid objects with openings used in DesignWorkshop.

Please don't hesitate to contact Artifice Technical Support for the latest information and assistance with any translation problems.


Software Conflicts


General Issues | Modeling | Lights and Textures | Translation | Conflicts

Known Incompatibilities

7200 Graphics Acceleration

At 2D zooms over 11,000% DesignWorkshop is prone to crash if the "7200 Graphics Acceleration" system extension is active . To avoid this problem, disable the 7200 Graphics Acceleration extension by removing it from the Extensions folder in your System folder, and then restarting the computer.


Artifice Foyer | Artifice Index | Guide Foyer | Guide Topics | Guide Index
© 1998 Artifice, Inc. - All Rights Reserved.