Artifice, Inc.
DesignWorkshop Tutorial


Part 1 -- Key Concepts for DesignWorkshop


Contents | Next Section

We at Artifice believe DesignWorkshop crosses a threshold of ease and power of use to make real three-dimensional architectural design in a digital environment practical for the first time.

DesignWorkshop has a simple, clear, classic direct-manipulation graphical interface to provide you with tremendous modeling flexibility, using just a few commands.

This design-oriented environment will let you get to work with a minimum of training time. However, 3D modeling is still at the top of the computer-graphics pyramid, and you'll probably need to spend a few hours and focus your energy to learn the key methods of DesignWorkshop. At first, DesignWorkshop will probably seem both familiar and alien, because, while it draws heavily from its ancestors, there's never been a 3D program quite like this before.

We like to break down the process of learning DesignWorkshop into four levels (severely abbreviated here), each one providing a foundation for the next.

Viewing

To get started, copy the application and sample file to your hard disk, and open the sample file with the DesignWorkshop application. Try out the direct-manipulation 3D viewing tools -- Eye and Look. Dragging in the scene with the Eye tool moves the viewpoint around the scene. To move into or out from the scene hold down the Option key (the Alt key for Windows) while dragging up or down. Also try out the 2D zooming and scrolling functions. Use the Window menu to open another window onto the model, and use the View menu functions to try out a variety of viewing and shading options in either window.

Basic Blocks, Openings, and Manipulations

The crucial methods of creating and manipulating blocks and openings are covered in detail in the next section of the manual. It is recommended that you take about an hour to carefully work through the introductory tutorial, and then come back to this summary learning outline. Once you have worked through the first structured tutorial, you'll be ready to start building objects on your own.

Picking up again at the end of the introductory tutorial, this learning guide will walk you through similar operations over again, but only in outline, so you can fill in the details as you go, modeling something simple but of interest to you.

Quit DesignWorkshop and start it up again by double-clicking on the application icon. This will give you a default new session with a new file open. Start out again by drawing a simple block. First click on the Block tool, then drag out the plan rectangle of the block in the scene with the 3D crosshair, and, without letting up on the mouse button, option-drag (depress the Option key (the Alt key for Windows) and drag) upward to pull up the height or "z" dimension of the block, finally letting go when you see what you want. Notice that the 3D crosshair stays at whatever height you leave it. To get the crosshair instantly back to the ground plane, type the number "0" on the keyboard. Between blocks you can also move the 3D crosshair to any height by option-dragging the mouse with the mouse button released.

To turn a massing block into a set of walls enclosing space, select it and give the Edit menu Wallify command. To put an opening in one of those walls, first click on it to select it, then click on the Opening tool icon in the tool palette. Position the cursor over the selected wall block, and you'll see it become a 2D crosshair in the face of the block.

2D crosshair in block face

Press the mouse button where you want to start, and drag out the opening. Do this in a wireframe view, and then again in a shaded view, where the operation can be rather slow but visually effective. After you've drawn an opening, select it by clicking in it, and drag by one of its selection handles to resize it, or drag from the middle to move the opening around in the wall.

Experiment with drawing 2D objects on the ground plane, and then making them three-dimensional by extruding them. First draw a shape with the Poly-line tool, clicking at each point along the line string, and double-clicking to end it as an open poly-line. DesignWorkshop will automatically supply a missing segment if necessary to form a solid when extruding.

option-dragging with the 3D crosshair
to extrude a poly-line into a solid.

To actually extrude the shape into a 3D solid, grab one of the handles of the poly-line's bounding rectangle, and pull up on it by option-dragging. There is no special command needed for extruding. Be sure that the 3D crosshair is actually aligned three-dimensionally with the handle you want to drag, or else you will move the poly-line rather than give it thickness.

A simple but very important interface feature in DesignWorkshop simplifies getting exact three-dimensional alignments. We call it Space-Jump, and you'll want to use it almost constantly to avoid subtle alignment errors when grabbing handles. Space-Jump converts a 2D alignment of the 2D cursor with a handle into a 3D alignment of the 3D crosshair with that handle, when you tap the spacebar. Try this on various handles of a selected block. Select the Arrow tool in the tool palette, and select a block. Then position the 2D cursor (a tiny plus sign in selection mode) over an object handle that is at a different height from the center of the 3D crosshair. Then tap the space bar, and notice how the 3D crosshair jumps over to the handle location.

Space-jumping to a handle, then dragging it

When object-snapping is on, you can Space-Jump to non-selected handles as well.

At this point you should be ready to explore most of the palette tools and menu commands. However, one important general issue remains for building sophisticated models.

Positioning in Three Dimensions

Up to this point, the tool use has mostly assumed working from the ground plane, zero elevation. We need to add to that the technique of working at other elevations in space. The two key tools for accurate working in free 3D space are the Space-Jump and "projection lines." Space-Jump, detailed above, allows instant setting of the crosshair to the elevation of an existing object handle, for instance to draw a roof on top of a wall or building mass. Projection lines are like outline shadows cast from objects at any height in space down onto the ground plane. You may have already noticed that these show automatically for selected objects and objects being created. The projection lines for other objects can be turned on and off with functions in the Arrange menu.

Your perceptual system will automatically and unconsciously use the projection lines in building a correct mental model of the 3D scene. For instance, without projection lines you might not be able to see the difference between a small block close to the view point and high above the ground versus a large block in the distance sitting on the ground.

How high above the ground is each of these three blocks?

Projection lines are also very useful for specific alignment tasks, used together with the little foot at zero elevation on the vertical line of the 3D crosshair. This crosshair foot becomes visible when the crosshair is lifted above or below zero elevation. Then it becomes helpful to align the crosshair foot with the plan grid and the plan projection lines of various objects, to ensure that crosshair positions in space are actually as intended.

Other functions that support particular alignment needs are drawing by coordinate entry in the location bar at the bottom of the model window, and the Object Info box (opened from the Layout menu), which allows display and direct editing of key object parameters including height and elevation. Sometimes it may be necessary to use orthographic views (plan, section, elevation) to check the relative position of objects in space. DesignWorkshop facilitates this, supporting both multiple windows of one model (for instance, for a plan view, an elevation view, and a working perspective, all at once) and also opening more than one model at a time. You can cut and paste objects between models using standard Macintosh clipboard methods.

Power Functions

After mastering the knack of drawing in free 3D space with the core tools of DesignWorkshop, you will have the basis for putting to use any remaining functions. High among these are the four Working Orientations, which let you rotate your 3D crosshair 'drafting machine from plan to elevation, or to any other rotation and position in the model world. Other advanced functions include shadow-cast renderings, animated sun studies and walkthroughs calculated directly to QuickTime movies, etc. With Apple System 7, DesignWorkshop supports publishing live 2D views of a 3D model out to subscribe-capable drawing/drafting software, permitting a whole drawing set and a multi-person project team to continuously synchronize to the 3D design model.


Contents | Next Section
Artifice Foyer | Artifice Index | Guide Foyer | Guide Topics | Guide Index
© 1998 Artifice, Inc. - All Rights Reserved.