Artifice, Inc.
DesignWorkshop Tutorial


Part 2 -- Basic Massing


Previous Section | Contents | Project Drawings | Next Section

1. If you haven't already installed DesignWorkshop (or DesignWorkshop Lite), install DesignWorkshop now by dragging the application folder onto your hard disk.

2. Start up the DesignWorkshop application by double-clicking on the application icon.

3. Thoughtfully look over the application environment. Notice the standard menu bar across the top of the screen, the tool palette on the left, the document window with the location bar across the bottom. Within the document window, notice the 3D workspace itself, with the 3D crosshair, grid lines at 5' spacing, and a north arrow. Move your mouse around and watch how the crosshair moves around in the modeling space.

This 3D crosshair is your fundamental tool in DesignWorkshop. Move the mouse forward to move the crosshair toward the back of the modeling environment. Pull the mouse back toward you so the crosshair is near the front side, or south, of the background grids. Observe that the 3D crosshair is actually in the modeling space, moving in perspective.

Now hold down the Option key (the Alt key for Windows) on your keyboard, and again move the mouse forward and backward. The 3D crosshair will move up and down vertically in the modeling space. Release and reapply the Option key while dragging some more. By combining plain- and option-dragging you can move the 3D crosshair freely about in space. Notice also that when the crosshair is lifted up off the ground plane, a little cross foot is visible at zero elevation. By watching this "crosshair foot", you can always track the crosshair's location relative to basic plan alignments.

Move the crosshair around in 3D until it feels comfortable. The next step is to start building.

4. Draw a block to be the mass of a simple two-story building: Click on the Block tool, tap the zero key to make sure the crosshair is on the ground plane, and then drag out a rectangle on the floor of the workspace, aligned to the background grid as shown below. Without releasing the mouse button, use your non-mouse hand to hold down the Option key (the Alt key for Windows) and drag up the height of the block with the mouse. As you option-drag, watch the number in the "V" field of the location bar to arrive at a height of 20 feet.

Creating a block in 3D

If the block comes out wrong at first, just Undo and draw it again. After some practice, creating a block like this in perspective will become second nature.

5. Notice that your crosshair ends up at the elevation of the top of the block. The crosshair can be moved up and down in the model space at any time by dragging the mouse with the Option key (the Alt key for Windows) down ("option-dragging"). But there are also some shortcuts for getting where you want to work quickly. First, watch the crosshair while you type the number "0" on the keyboard again (without clicking the mouse at all). The crosshair drops to zero elevation. You can jump to any elevation from 0 to 9 similarly with one keystroke.

More usefully, you can also jump to any handle on a selected block. To get the crosshair back to the top of the massing block, position the 2D cursor over one of the top corner handles of the block, temporarily ignoring what's going on in 3D. Then hit the space bar on the keyboard. The 3D crosshair "space-jumps" to the exact 3D location of any handle under the 2D cursor, and out the relative coordinates in the location bar are zeroed out.

Try this out. With the block you've made still selected, position the drawing cursor over the selection handle at the front, left, top corner of the massing block, and then just tap the space-bar on your keyboard. If the crosshair was already aligned to the same height as that corner of the block, only the numbers in the right half of the location bar will change (they should all read "0" after the space jump). However, frequent use of the space jump is a good habit to develop -- it's a crucial tool to help you accurately establish the correct elevation to draw at.

6. Now draw a block for a roof. The Block tool should still be highlighted in the tool palette, and the crosshair should be at the correct height due to the last space jump, so you can just position the crosshair horizontally and draw. Confirm that the Z field of the location bar reads 20', then move the crosshair off from the block corner a foot to the west and to the south for an overhang, then drag horizontally to the diagonally opposite corner, so the location bar E field reads 27 and the S field reads 22, and then finally hold down the Option key (the Alt key for Windows) and continue dragging upward a few feet until the V field reads 10. As you draw, notice that a projection of your block in plan is continuously updated on the ground plane (at zero elevation). These "projection lines" are an important aid to perception of depth in the perspective space -- use them to help size and position the roof block.

When you release the mouse button, the Block tool stays on, and the last block stays selected (until you draw another) so its projection lines remain visible.

Drawing a block for the roof

7. Now, let's adjust our view to make the next step easier. Click on the Eye tool, and then to move a few degrees around the model to the right, drag the eye cursor across the window gradually to the right, and also up a little. Stop when your view of the model matches the next illustration.

8. Now make that coarse block into a gable roof. Notice that the block has mid-edge handles showing, which can be distinguished as unfilled white squares. In general, dragging on a mid-edge handle moves one edge of an object, changing its shape rather than its overall size.

First click on the selection arrow (in the tool palette) to return to the default mode. Then space-jump the 3D crosshair to the top mid-edge handle on the south, front, of the roof block (by positioning the 2D cursor, and then tapping the crosshair).

Then mouse-down and drag the edge to form half a ridge line in the middle of the roof. Watch the projection lines on the ground plane to help align to the center.

Then space-jump to the top back mid-edge handle, and drag it to join the other at the ridge line, completing the gable form.

You should now have a gable roof. Pull down the View menu and turn on Shading to see the solid mass of the little house. Double click the selection arrow to deselect everything and get the handles out of the way.

Shaded view of the gable roof

9. Select the Eye tool and drag the eye cursor around the window a bit to admire your creation, and the dynamic view manipulation of DesignWorkshop. When you're done admiring, return the view to about the same angle we just used, looking downward and toward the east end of the little building.

10. This would be a good time to save your work. As with any software, with DesignWorkshop you should save frequently. Use the File menu Save command. Then for convenience turn off shading by pulling down the View menu to the Wireframe command.


Previous Section | Contents | Next Section
Artifice Foyer | Artifice Index | Guide Foyer | Guide Topics | Guide Index
© 1998 Artifice, Inc. - All Rights Reserved.